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Problem
GlobalProtect on Mac sometimes appears to get stuck. It just sits at Connecting and won't connect. Retrying the connection and restarting the machine do not resolve the issue.
Cause
GlobalProtect is missing a security permission. GlobalProtect needs to run at the system level, but has not been granted security permission to run at system level. During the installation of GlobalProtect, if you did not click on the Open Security Preferences button to allow the extension (or the dialog did not appear), GlobalProtect will be unable to connect.
Solution
You can give GlobalProtect the required security permission manually on the Security and Privacy screen in System Preferences. GlobalProtect is produced by Palo Alto Networks and must be granted permission to run as system software.
Follow these steps:
- Reboot your Mac and try to connect GlobalProtect again.
- From the Apple menu (top left corner), select System Preferences...
- Click on the Security & Privacy icon.
- Click the lock icon at the bottom left and enter your password so that you can make changes.
- On the General tab, there may be messages at the bottom stating "System software from <company> was blocked from loading." There could be several messages queued, so click Allow until you see the message about Palo Alto Networks.
- Click Allow to the "System software from Palo Alto Networks was blocked from loading."
- Click the lock icon again to prevent further changes.
- Close System Preferences and restart your Mac.
- After rebooting, connect GlobalProtect.
More information
Palo Alto Networks has published a support article about this issue:
https://knowledgebase.paloaltonetworks.com/KCSArticleDetail?id=kA10g000000boQ9CAI
This second article from Palo Alto Networks shows the screens to grant security permission:
https://knowledgebase.paloaltonetworks.com/KCSArticleDetail?id=kA10g000000PP9pCAG