Problem
After receiving notification that a new version of GlobalProtect is ready to install and clicking Yes to continue, the GlobalProtect icon disappears from the system tray and nothing further happens.
Cause
This issue occurs because there is another install in progress on the computer and the GlobalProtect installation program cannot launch until the prior install completes.
When performing a self-upgrade, GlobalProtect disconnects from the VPN, unloads itself from memory, and requests the Windows Installer system to install the new software version. But if the Installer system is busy, the GP upgrade is queued until that first install completes.
This occurs most frequently on devices that are managed by Azure AD/Intune. This system actively updates the software versions on managed devices, so it is possible that it may have been installing an update at the same time that GlobalProtect decided to upgrade.
Other software that performs frequent self-upgrades include web browsers like Chrome or Firefox and cloud service apps like Messenger or Dropbox. Pending Windows Updates may also prevent GlobalProtect from upgrading.
Solution
The recommended solution is to reboot your computer. This is often all that is required to complete the pending software installs.
If a reboot does not solve the problem, please open a ticket with the Service Desk.