Known Issue: GlobalProtect on macOS stuck at Connecting

Tags mac vpn

Problem

GlobalProtect on Mac sometimes appears to get stuck. It just sits at Connecting and won't connect. Retrying the connection and restarting the machine do not resolve the issue.

Cause

GlobalProtect is missing a security permission. GlobalProtect needs to run at the system level, but has not been granted security permission to run at system level. During the installation of GlobalProtect, if you did not click on the Open Security Preferences button to allow the extension (or the dialog did not appear), GlobalProtect will be unable to connect.

Solution

You can give GlobalProtect the required security permission manually on the Security and Privacy screen in System Preferences. GlobalProtect is produced by Palo Alto Networks and must be granted permission to run as system software.

Follow these steps:

  1. Reboot your Mac and try to connect GlobalProtect again.
  2. From the Apple menu (top left corner), select System Preferences...
  3. Click on the Security & Privacy icon.
  4. Click the lock icon at the bottom left and enter your password so that you can make changes.
  5. On the General tab, there may be messages at the bottom stating "System software from <company> was blocked from loading." There could be several messages queued, so click Allow until you see the message about Palo Alto Networks.
    Allow Apps icon
  6. Click Allow to the "System software from Palo Alto Networks was blocked from loading."
  7. Click the lock icon again to prevent further changes.
  8. Close System Preferences and restart your Mac.
  9. After rebooting, connect GlobalProtect.

More information

Palo Alto Networks has published a support article about this issue:
https://knowledgebase.paloaltonetworks.com/KCSArticleDetail?id=kA10g000000boQ9CAI

This second article from Palo Alto Networks shows the screens to grant security permission:
https://knowledgebase.paloaltonetworks.com/KCSArticleDetail?id=kA10g000000PP9pCAG

 

100% helpful - 1 review

Details

Article ID: 107379
Created
Mon 5/11/20 7:09 PM
Modified
Tue 5/12/20 11:05 AM

Related Articles (1)

Virtual Private Network (VPN) technology provides secure remote access and secure data transmission between devices that are not connected to the University wired or wireless campus networks and University systems. The the Palo Alto GlobalProtect software that you can install on your computer makes it seem as if it is on the campus network by setting up a tunnel which encrypts all traffic between your computer and the University firewall. This article is intended for Apple Mac users.